Thursday, April 9, 2015

Troubleshooting eBGP peering

Simple .... BGP topology ... can you get eBGP up and running between R1 and R2?

Objective:

Establish successful and stable eBGP relationship between R1 and R2. With the current start-up config, BGP is IDLE. 

Topology diagram and startup config are posted below.



Now obviously the Objective is fairly simple, so let's make it interesting with these restrictions.

Restrictions:
  • No BGP filtering on outbound / inbound using route-map/distribute-list/filter-list/prefix-list etc.
  • All routes currently advertised via BGP must be in the BGP table. 
  • Do not use the multi-hop command
  • No static routes
  • No redistribution 
  • Do not introduce new protocols
  • Do not change metrics/distance of routes
  • Do not configure any OSPF inbound/outbound filtering.
Startup configs are as follows:

 R1#sh run int lo1  
 interface Loopback1  
  ip address 1.1.1.1 255.255.255.255  
  ip ospf 1 area 0  
 end  
 R1#sh run int gig1.11  
 interface GigabitEthernet1.11  
  encapsulation dot1Q 11  
  ip address 192.168.1.1 255.255.255.0  
  ip ospf 1 area 0  
 end

 R1#sh run int gig1.12  
 !  
 interface GigabitEthernet1.12  
  encapsulation dot1Q 12  
  ip address 12.12.12.1 255.255.255.0  
 end  
 R1#sh run | sec bgp  
 !  
 router bgp 1  
  timers bgp 1 3
  network 1.1.1.1 mask 255.255.255.255  
  neighbor 2.2.2.2 remote-as 2  
  neighbor 2.2.2.2 update-source Loopback1  
 R1#  

 R2#sh run int lo2  
 interface Loopback2  
  ip address 2.2.2.2 255.255.255.255  
  ip ospf 1 area 0  
 end  
 !
 R2#sh run int gig1.11  
 interface GigabitEthernet1.11  
  encapsulation dot1Q 11  
  ip address 192.168.1.2 255.255.255.0  
  ip ospf 1 area 0  
 end

 R2#sh run int gig1.12  
 !  
 interface GigabitEthernet1.12  
  encapsulation dot1Q 12  
  ip address 12.12.12.2 255.255.255.0  
 end
 !  
 R2#sh run | sec bgp  
 !  
 router bgp 2  
  timers bgp 1 3  
  network 2.2.2.2 mask 255.255.255.255
  neighbor 1.1.1.1 remote-as 1
  neighbor 1.1.1.1 update-source Loopback2
 R2#  

Post comments on how you would fix this.

Many more articles to come so ....

Please subscribe/comment/+1 if you like my posts as it keeps me motivated to write more and spread the knowledge.

No comments:

Post a Comment